Canon EOS Utility & Mac OS X Lion

Canon EOS Utility & Mac OS X Lion

ATTENZIONE: questa guida è ormai OBSOLETA. Le ultime versioni del software (disponibile nell’area download Canon) risolvono il problema di compatibilità con Lion.

—————— —————— —————— —————— —————— —————— ——————

Visto che ieri mi è arrivata la mia prima reflex digitale, una Canon 550D, inauguro il primo post relativo alla fotografia di questo blog appuntando (per me e per i posteri) un trucco che ho trovato fare per installare la EOS Utility (software incluso con la macchina che permette di controllarla completamente da remoto) in Mac OS X Lion 10.7, visto che ovviamente l’ultima versione disponibile sul sito Canon (2.10.2) non è compatibile e restituisce un bell’errore come questo:

EDIT del 04/01/2012:
grazie al suggerimento di DDAAXX ho inserito un nuovo post con un nuovo workaround che permette di utilizzare l’ultima versione dell’utility su Lion. Vi consiglio di seguire quella! 😉

EDIT del 30/01/2012:
finalmente la EOS Utility è stata ufficialmente aggiornata alla versione 2.10.4 per supportare nativamente MAC OS X 10.7 Lion. Ancora non si trova nel sito italiano, ma la potete scaricare qui dal sito asiatico. Meglio tardi che mai! 😉

Il trucco sta stava semplicemente nell’installare una versione precedente (la 2.8.1) che, incredibilmente, non è afflitta da questo errore.

Per fortuna si trova ancora nel sito asiatico di Canon, a questo link.
(Il link non è più disponibile con l’arrivo delle nuove versioni dell’utility, che potete trovare nell’area download Canon)

La procedura per l’installazione (È OBSOLETA !!! LEGGI SOPRA!) è la seguente:

  • Rimuovere ogni versione precedente di EOS Utility (basta cestinare la cartella)
  • Scaricare la versione 2.8.1, scompattarla e montare il DMG
  • Copiare l’UpdateInstaller in un’altra cartella (per esempio sul Desktop)
  • Cliccare col tasto destro sull’installer e andare in “Mostra contenuto Pacchetto
  • Cliccare col tasto destro sul pacchetto “SDI.bundle” e andare in “Mostra contenuto Pacchetto
  • Cancellare il file Contents/Resources/update.plist
  • Installare UpdateInstaller appena modificato seguendo normalmente le istruzioni.
In attesa ovviamente che Canon rilasci a breve una versione di tale Utility aggiornata e compatibile con Lion.

A proposito Alessandro

Ingegnere delle Telecomunicazioni con propensione al web2.0 ed il pallino della tecnologia; toscano & casentinese, vivo a Firenze