compat-wireless: finalmente i Ralink rt2x00 tornano a funzionare

Segnalo che finalmente dopo diverso tempo con l’aggiornamento di oggi ( 16 aprile 2008 ) tornano a funzionare i driver ralink rt2x00 dentro il pacchetto di driver wireless “compat-wireless“.

Dopo la versione 2.0.14 (che avevo trovato molto stabile), si sono succedute infatti varie versioni e modifiche che ne avevano compromesso la stabilità.

In particolare è finalmente stato risolto un bug alla funzione “lib->config_filter()” che mandava tutto in loop…

Adesso con l’ultimo aggiornamento sono passato alla versione 2.1.14, che risulta ottima sia in stabilità che in prestazioni. Consiglio quindi a tutti i possessori di schede ralink di aggiornare, seguendo la solita procedura

Edit del 22/04/2008:
dalle prove che ho fatto successivamente sembra che questa nuova versione non sia poi cosi stabile come la precedente. Per il momento sono tornato alla 2.0.14 “rock-stable”, in attesa di ulteriori indagini e prove…

La brutta notizia è che in Ubuntu Hardy, ormai prossima al rilascio, è presente la versione 2.0.10, che pur connettendosi e funzionando out-of-the-box, risulta assai instabile e buggata, almeno dalle mie prove con il chipset rt73 (e quindi il modulo rt73usb). Gli utenti che installano Hardy per la prima volta saranno dunque costretti ad aggiornare i driver se vorranno vedere la propria periferica ralink perfettamente funzionante…

Speriamo che i responsabili dei pacchetti intervengano presto a tappare questa falla…

Aggiunta del 22/04/2008:
sembra proprio che l’Ubuntu-Team abbia deciso di ascoltare la mia richiesta (che in realtà è quella di molti). Grazie ad una segnalazione tra i commenti, ho scoperto che in hardy è disponibile un pacchetto di backports che aggiorna i driver ralink ad una versione più stabile. Basta selezionare e installare il pacchetto linux-backports-modules-hardy
Sembra che l’installazione dei compat-wireless non sarà dunque necessaria…

Ben fatto guys! 😉

A proposito Alessandro

Ingegnere delle Telecomunicazioni con propensione al web2.0 ed il pallino della tecnologia; toscano & casentinese, vivo a Firenze

  • da qualche giorno stanno lavorando a un pacchetto backport dal 2.6.25

    https://bugs.launchpad.net/bugs/134660

    ciao

  • Grazie NoWhereMan!!!
    Gran bella notizia mi hai dato!

    Sto installando adesso il pacchetto linux-backports-modules-hardy, che è già presente nei repo di Hardy!

    Vi farò sapere!!! 😉

  • axr

    ciao li ho installati ora sulla mia scheda pci che monta il chio 2500 navigo male luci della scheda non si accendono nè quella verde ne quella arancione.. mi sembra strano non trovi!!!! anch’io ho avuto problemi con i precedenti driver ed ho reinstallato i precednti… che mi consigli di rimettere i precedenti?
    ciao grazie

  • Anche le luci della mia sono spente, ma apparte questo funziona bene. Tu hai anche problemi di funzionamento?

  • axr

    con rutiliT la qualità del segnale è di pochissimo più alta dei precedenti i 2.0.14, sembra vada bene anche se a volte sembra leggermente più scattosa la pagine, ora provo con amlue come scarica, magari è una mia impressione che vedendo le luc spente penso non siano abbastanza buoni per la mia scheda, speriamo che i led spenti non siano sintomatici di un funzionamento parziale. c’è un modo per testare la qualità del segnale e la velocità?
    ciao

  • Le lucette vogliono dire poco…

    L’unico modo per testare segnale e velocità è stressare la chiavetta con sessioni p2p o scaricando immagini grosse, come immagini Iso…

    Anche io noto che il segnale è un po’ aumentato! 😉

  • axr

    una cosa però, mi è sparita l’icona della partizone ntfs sul desktop… non chiedermi poerchè ma è così.. come devo fare§?
    ciao

  • Axr

    ciao dopo aver provato i driver tutto ieri ho reistallato i 2.0.14, problemi riscontrati:
    amelu non scaricava, firefox si inchiodava il dowload o andava a singhiozzi, lo streaming era scattoso, ho provato col sito della rai, le pagine non si aprivano fluidamente.
    con i precedenti fila tutto liscio. sarà che la mia scheda pci non li digerisce… grazie di tutto
    ciao alla prossima..
    PS. uso network manager che a quanto pare non mi da problemi non credo dipenda da quello quindi anche se ero tentato di provare wicd, ma quando lo feci non riuscii a collegarmi con la wireless..
    A presto

  • Beh grazie del tuo resoconto..
    Mi puoi dire che chipset hai? e poi, Gutsy o Hardy?

  • Axr

    hai ragione…
    ho gutsy la scheda un pci ha il chip rt2500..
    un’altra coa ho notato, da quando ho installato questi driver, la scheda bradcom integrata non viene più vista anche con il firmware caricato e levati i diver bcmxxx dalla blacklist, noon che sia un problema certo ma era solo una sfida che avevo perso 3 distro fa…
    spero di essere stato chiaro.
    ciao alla prossima

  • Certo, questi compat-wireless aggiornano anche i driver broadcom, sostituendoli con i nuovi b43 (presenti di default a partire dal kernel 2.6.24, quello di hardy).
    Devi solo aver cura di disabilitare i bcmxxx e caricare il nuovo firmware (procedura descritta nel wiki di ubuntu-it) ed è probabile che pure la broadcom torni a funzionare.. 😉
    A sto punto forse ti conviene mettere hardy no? Ormai manca poco al rilascio!
    Ciao!

  • Axr

    magari, ho provato a lanciare il cd live ma si blocca e non va avanti.. mi da questi errori:
    b44 ssb01: Problem fetching invariant of chip
    ppoi inizia a caricare e si blocca qui
    loading hardware drivers
    …e muore il caricamento
    ma non ho trovato nulla a riguardo.. credo che mi dovro tenere gutsy!!!!
    ciao!

  • per via di altri problemi che per ora mi costringono a ricompilare completamente il kernel sono su 2.6.25; per curiosità, wicd vi funziona? a me con rt61pci a smesso di funzionare da parecchio e sto usando wifi-radar (e n-m)

    se fosse tornato a funzionare forse potrei provare a re-installarlo (tappandomi con forza il naso, perché wicd non mi piace per niente)

  • A me funziona benissimo… anche su hardy (ed ha sempre funzionato).
    Forse potresti provare a reinstallarlo, cancellando completamente il profilo che viene creato dentro /opt/wicd

    Comunque se non ti piace perchè devi essere costretto ad usarlo? In fondo funziona anche network-manager… scegli quello con cui ti trovi meglio ! 😉

  • dovrei usarlo perché N-M ha problemi con la mia rete WPA2; non mi piace perché è IMO è mal progettato sia tecnicamente che dal punto di vista dell’usabilità

  • Anjie

    La wireless con Hardy funziona, anche se solo con cifratura Wpa. Purtroppo però la connessione risulta lentissima. Scarica a 8 kbss contro i 500 kbs ottenuti scaricando lo stesso file tramite connessione cablata due minuti dopo. I linux-backports-modules-hardy non cambiano nulla. Qualcuno riscontra lo stesso problema?

  • Paolo

    Anch’io vedo velocità ridotta, e disconnessioni frequenti con rt2500 – con rt73 sembra + regolare ma lenta