wicd 1.4.1, finalmente la stable

Dopo l’uscita pochi giorni fa della 1.3.9, ecco spuntare oggi la versione 1.4.1 di wicd, targata “STABILE“, dopo molti mesi di sviluppo continuo.
(La 1.4.0 in realtà è uscita ma è durata poche ore, causa una piccola svista).

Poco cambia dalla 1.3.9, invece notevoli sono i miglioramenti dalla versione stabile precedente, la 1.3.1 uscita il 08/07/2007.

Dato che uno changelog completo per adesso non esiste, non vi resta che provare questa nuova versione.

Per evitare problemi, consiglio di disinstallare completamente la versione precedente e rimuovere il profilo prima di installare la nuova versione.

In Ubuntu/Debian si possono usare i seguenti comandi:

sudo apt-get remove --purge wicd
sudo rm -r /opt/wicd

Il pacchetto deb per Ubuntu è disponibile qui, mentre le istruzioni per le altre distribuzioni si trovano in questa pagina.

A breve dovrebbe venir aggiornato anche il repository
deb http://apt.wicd.net gutsy extras

Di seguito lo screenshot

A proposito Alessandro

Ingegnere delle Telecomunicazioni con propensione al web2.0 ed il pallino della tecnologia; toscano & casentinese, vivo a Firenze
  • wpa

    ah , bene,
    provo con questa

  • fai un bel riassuntino dei vantaggi di questo programma?

  • wpa

    saro’ sfortunato ma con la 1.4.1 ho grossi problemi con eth0, oltre al “solito” problema con la wpa che non va

    #ciso
    i vantaggi dovrebbero essere nel non dover inserire password dopo il login, pur mantenendo un login automatico
    e, presumo (sto ancora cercando di farlo funzionare in wpa…..) di non avere i problemi di network-manager in caso di interruzione/ripresa della rete wireless

  • Ciso, ho già scritto una guida molto dettagliata a riguardo.
    Clicca su link della parola “wicd” di questo post 😉

  • AlexTG

    @ Alexit

    Fino alla versione 1.3.9 non ho avuto problemi di dipendenze, visto che da pochi giorni ho deciso di passare ad un’installazione pulita di Kubuntu; oggi ho provato a ripulire e reinstallare Wicd come da te indicato, ma mi chiede di installare 46 dipendenze (tutte librerie di Gnome a occhio e croce), quindi per ora ho desistito tornano alla vecchia versione. Dici che è stato semplicemente “pacchettizzato” male il file DEB?

  • quali sono le dipendenze che ti chiede?

  • rew

    kubuntu gutsy 7.10 2.6.22-14-generic
    mah io francamente ho un problema con il tray icon ho la 1.41 ma avevo la 1.38 e 1.40, cmq se si fa tasto sinistro sulla icona-tray nulla, quella di default che viene caricata all’avvio.
    ho provato allora a lanciare da shell l’icona:
    @: /opt/wicd/tray.py
    bene me ne trovo due clicco su questa faticosamente su quella creata e ci va, sull’altra niente.
    vediamo il file
    @:gvim opt/wicd/tray.py

    #!/usr/bin/python
    import os,sys
    if __name__ == ‘__main__’:
    os.chdir(os.path.dirname(os.path.normpath(os.path.join(os.getcwd(),sys.argv[0]))))
    import gtk
    if gtk.gtk_version[0] >= 2 and gtk.gtk_version[1] >= 10:
    import edgy
    else:
    import dapper

    non dovrebbe esserci anche qualcosa per gutsy ?

  • AlexTG

    @ Alexit

    Ho fatto uno screenshot altrimenti ti intaso il blog…

    http://img527.imageshack.us/img527/928/dipendenzepg9.png

  • ciao! veramente bello questo wicd, lo uso da un bel po’. (grazie alla tua segnalazione!!)
    quello che non mi piace dell’ultima versione è che, immagino per seguire le linee guida di GNOME, ora l’icona nella systray non è più presente… che voi sappiate esiste un modo per riabilitarla??
    a me faceva comodo!

  • wpa

    se puo’ essere utile, con app che non caricano correttamente le icone in gnome per colpa di gnome o di compiz
    chiamo da sessioni uno script invece dell’app stessa
    e cosi’ non ho problemi

    ad esempio per wicd

    #!/bin/bash

    sleep 2
    /opt/wicd/tray.py

  • Ciao!
    ho finalmente tolto di mezzo quel troiaio di Network Manager ed ho installato wicd nel mio serverino in cantina, ora sì che funziona, finalmente…..
    Complimenti per gli articoli passati…soprattutto quelli sul Wireless

  • come non detto, forse era solo un problema di mancato riavvio…
    adesso anzi l’iconcina fa illuminare anche gli schermini del pc fase di trasmissione e ricezione 🙂

  • mau

    un saluto a tutti e buon anno

    sto utilizzando wicd su Kubuntu Gutsy e funziona a dovere con la rete cablata mentre con il wifi se clicco su connetti tenta di assegnare l’indirizzo ip ma invano …. (ho il router in dhcp e su quella cablata non ha problemi nell’assegnazione dell’indirizzo)
    ho una bcm43xx su hp con driver e firmware fw-cutter
    uso una wpa-psk
    al primo utilizzo mi ha funzionato tutto e ora non saprei cosa pensare
    il router l’ho verificato (ma non avevo cambiato impostazioni)
    ciao e un grazie a @AleXit per il suo impegno

  • @mau anche io avevo lo stesso problema con il wireless e eicd 1.4.1. Ho risolto (ancora una volta non puo’ trattarsi che di poltergeist) rimettendo la chiave WPA sull’access point (corrisponde al tuo router). I log dell’access point mi davano infatti un errore di autenticazione.

    (il bello e’ che da windows con la stessa chiave riuscivo a collegarmi 🙂

  • mau

    @francesco ti ringrazio per il tuo reply
    non è la prima volta che mi incaponisco con wicd su Kubu e mi scorno spesso
    questa volta sembrava essere andato tutto per il meglio (era addirittura comparsa l’icona e le immagini erano regolari) e ho veramente provato di tutto compreso il tuo suggerimento …. però senza esito e sono mestamente ritornato a KNetwork
    ciaociao

  • NevidS

    Anche io mi chiedevo come AlexGT come mai la versione 1.4.1 rispetto alle versioni precedenti richiede tutte quelle dipendenze. Oo

  • AlexTG

    @ NevidS

    Se non sbaglio eri tu che aveva problemi con la Netgear WG111T come me mesi fa: hai mai avuto dei blocchi (anche del sistema, tipo Kernel Panic) per caso dovuti alla perdita del segnale?

    @ Tutti
    Scusate l’OT (solo parziale).

  • NevidS

    AlexTG (che nel post precedente ho storpiato il tuo nome, sorry :P) sisi, ero io ad avere la tua stessa pennetta. Problemi di Kernel Panic no, non ne ho avuti, ma da quando ho installato la 1.4.1 alla perdita del segnale hanno ripreso i blocchi di sistema cosa che mi si presentavano con le prime versioni di wicd.
    Adesso sono tornato indietro ala 1.3.9 che mi dava l’idea di funzionare meglio sul mio pc, però è solo una idea. Magari non centra nulla ed è solo una casualità, anche perchè in questo stesso periodo il mio ISP (Infostrada) mi fa navigare a 51Kbs quindi le disconnessioni sono tante con i conseguenti blocchi.

  • ottimo soft

    ottimo soft, ma meglio lasciar perdere questa “stabile”
    sul mio pc ha qualche baco di troppo
    dimostrato forse dal fatto che dopo una settimana non e’ stata ancora aggiunta alla repository

    l’unica rel “stabile” e’ la 1.3.1: il caso.. e’ l’unica in repo 😉

  • Ottimo software, strano che non sia molto conosciuto..almeno io l’ho conosciuto tramite i tuoi post. Finalmente riesco a far tenere la wpa su un vecchio portatile con una pcmcia d-link.. bella anche la tray-icon. Ho installato dal repository di gutsy senza dover fare nient’altro, quindi aggiorna tranquillamente il post che nei repo wicd c’è, e se ne va anche il problema del conflitto con network-manager. Ciao, e grazie della segnalazione!

  • a me su ubuntu 7.10 or funzion, previa disinstallazione di NM.
    L’unica cosa che non mi va è la connessione al network predefinito all’avvio, wicd parte ma non si aggancia nonostante il netwok configurato abbia il segno di spunta a posto.

  • Marcello

    Ciao scusate ma non riesco proprio a farlo funzionare!non mi rileva la rete wireless…eppure la scheda è installata(ath0)…qualcuno mi aiuti!!!
    grazie

  • nelle preferenze di wicd, controlla che il nome dell’interfaccia wireless sia correttamente impostato su ath0

  • FabrX

    Salve…
    premetto che sono nuovo a Linux e ho cominciato con Ubuntu.
    Scrivo perché volevo ringraziare REW.
    Grazie a te ho saputo il comando per far vedere l’icona e l’ho messo in system=>preference=>session rendendola visibile.
    Non so se ho fatto un accrocco ma funziona…
    Grazie

  • michele

    ciao ragà….davvero ottimo rispetto a quella ciofeca del network-manager predefinito in ubuntu 7.10…solo una curiosità,come faccio ad autenticare i pacchetti del repositore postato?
    aspetto tue risposte…grazie 1000 in anticipo.
    michele

  • Il repository di Wicd non ha bisogno di autenticazione, basta inserirlo nel file /etc/sources.list

    Ciao

  • debianizzatoo

    Ciao AleXit , vorrei farti una domanda : come faccio ad avviare la tray icon su debian ?? i comandi che ho trovato nel tuo blog per ubuntu sembrano non andare.Come se fa ??